definesMessageType

P11573
predicate

Indicates that one entity specifies or determines the message type classification or category for another entity.

All labels observed (3)

Label Occurrences
definesMessageType canonical 75
messageTypeCode 3
messageTypes 3

Description generation (PDg)

The one-sentence description above was generated by prompting gpt-5.1 with the predicate name and this instruction.

Instruction
Given a predicate that represents a relationship or action between entities, generate a one-sentence description explaining its meaning.  
# Instructions
Focus on describing the relationship, not the entities themselves. 
# Response Format
Begin the description with \' Indicates...\'
Input
Predicate: definesMessageType
Generated description
Indicates that one entity specifies or determines the message type classification or category for another entity.

Sample triples (81)

Subject Object
RFC 4252 SSH_MSG_USERAUTH_REQUEST ⓘ
RFC 4252 SSH_MSG_USERAUTH_FAILURE ⓘ
RFC 4252 SSH_MSG_USERAUTH_SUCCESS ⓘ
RFC 4252 SSH_MSG_USERAUTH_BANNER ⓘ
TLS 1.2 Finished message 20 in TLS 1.2 handshake protocol via predicate surface "messageTypeCode" ⓘ
RFC 792 ICMP Echo Request ⓘ
linked to: ICMP
RFC 792 ICMP Echo Reply ⓘ
linked to: ICMP
RFC 792 ICMP Destination Unreachable ⓘ
linked to: ICMP
RFC 792 ICMP Source Quench ⓘ
linked to: ICMP
RFC 792 ICMP Redirect ⓘ
linked to: ICMP
RFC 792 ICMP Time Exceeded ⓘ
linked to: ICMP
RFC 792 ICMP Parameter Problem ⓘ
linked to: ICMP
RFC 792 ICMP Timestamp ⓘ
linked to: ICMP
RFC 792 ICMP Timestamp Reply ⓘ
linked to: ICMP
RFC 792 ICMP Information Request ⓘ
linked to: ICMP
RFC 792 ICMP Information Reply ⓘ
linked to: ICMP
RFC 826 ARP packet ⓘ
RFC 826 ARP request packet ⓘ
RFC 826 ARP reply packet ⓘ
RFC 2131 DHCPDISCOVER ⓘ
RFC 2131 DHCPOFFER ⓘ
linked to: DHCP
RFC 2131 DHCPREQUEST ⓘ
RFC 2131 DHCPDECLINE ⓘ
RFC 2131 DHCPACK ⓘ
RFC 2131 DHCPNAK ⓘ
RFC 2131 DHCPRELEASE ⓘ
linked to: DHCP
RFC 2131 DHCPINFORM ⓘ
RFC 783 RRQ ⓘ
RFC 783 WRQ ⓘ
RFC 783 DATA ⓘ
RFC 783 ACK ⓘ
RFC 783 ERROR ⓘ
RFC 1350 RRQ ⓘ
RFC 1350 WRQ ⓘ
RFC 1350 DATA ⓘ
RFC 1350 ACK ⓘ
RFC 1350 ERROR ⓘ
MIL-STD-1553 databus command via predicate surface "messageTypes" ⓘ
MIL-STD-1553 databus status via predicate surface "messageTypes" ⓘ
MIL-STD-1553 databus data via predicate surface "messageTypes" ⓘ
RFC 5766 Allocate request ⓘ
RFC 5766 Allocate response ⓘ
RFC 5766 Refresh request ⓘ
RFC 5766 CreatePermission request ⓘ
RFC 5766 ChannelBind request ⓘ
RFC 5766 Send indication ⓘ
RFC 5766 Data indication ⓘ
RFC 903 RARP request ⓘ
RFC 903 RARP reply ⓘ
DHCPDISCOVER 1 via predicate surface "messageTypeCode" ⓘ